Installation

Installing RiotQuest is extremely simple. You'll only need PHP and Composer installed.

Prerequisites

  • PHP v7.1+ (RiotQuest uses Type Hinting, hence no 7.0 support.)
  • PHP-extension CURL
  • PHP-extension JSON
  • Composer

Installing RiotQuest

RiotQuest comes as a packagist.org package. You'll install it via Composer.

$ composer require supergrecko/riot-quest